icon
Avatar
Abisem
Post: 211
Ciao a tutti,
sto provando a installare per la prima volta Contao 2.9.3.0 scaricato dal vostro sito sul mio server Windows Server 2008, ma il tutto sembra partito con il piede sbagliato :P

Andando a lanciare l'installazione, infatti, incontro due problemi differenti:

- con Firefox 4 mi dice "Empty referer address!" (cosa che mi diceva anche quando ho tentato di registrarmi al forum, infatti ho dovuto cambiare browser), ma se non ho capito male dalle FAQ dovrebbe essere un problema di configurazione del browser stesso;

- lanciando l'installazione con un altro browser mi si presentano le condizioni di utilizzo... ma pur cliccando su accetto continuano a ripresentarsi come se fosse andato in loop... cosa sbaglio?

Ho provato a fare una ricerca veloce nel forum e su Google ma non riesco a capire cosa non vada... potrebbe essere un problema di permessi di scrittura? Avete qualche suggerimento da darmi visto che il server del mio studio è un IIS 7 su Windows Server 2008 e che, se dovessi sviluppare con Contao, sicuramente girerebbe su quella macchina?

Grazie mille per il tempo che mi dedicherete e scusate se per voi è una banalità, ma vista l'ora e la giornata di lavoro alle spalle potrei anche sbattere la testa contro un muro prima di accorgermi che c'è :)
[L'ultima modifica di Abisem, 23/03/2011 22:11]
Pluralitas non est ponenda sine necessitate.
23/03/2011 21:56
Avatar
PaoloB
Moderatore
Post: 1550
iconAbisem:

Ho provato a fare una ricerca veloce nel forum e su Google ma non riesco a capire cosa non vada... potrebbe essere un problema di permessi di scrittura? Avete qualche suggerimento da darmi visto che il server del mio studio è un IIS 7 su Windows Server 2008 e che, se dovessi sviluppare con Contao, sicuramente girerebbe su quella macchina?


Ciao, benvenuto tra noi.

Quando si accetta la licenza, viene annotata questa operazione sul file di configurazione.
la tua ipotesi è corretta, sembra vi siano problemi di scrittura sul file. Devi verificare che PHP possa scrivere alcune cartelle e file di contao, in particolare:

File
/system/config/localconfig.php

Cartelle
/system/html
/system/logs
/system/tmp
Paolo B.
paolob@contaocms.it
23/03/2011 22:12
Avatar
Abisem
Post: 211
Ciao PaoloB,
grazie per la tua celere risposta.

In effetti in locale (Windows XP SP3) sono riuscito a installarlo senza problemi e cambiando i permessi come mi hai consigliato, l'ho installato anche in remoto :thumbup:
Pluralitas non est ponenda sine necessitate.
23/03/2011 22:32
Avatar
visionecreativa
Post: 226
Ciao se sei interessato ho inserito dei videotutorial sull'installazione di Contao su contaotutorial.
Potrebbero venirti utili.

Ciao.
Maurizio A.
www.visionecreativa.com
www.contaotutorial.com
23/03/2011 22:59
Avatar
Abisem
Post: 211
Li guarderò sicuramente visionecreativa, avevo già addocchiato il sito cercando su Google informazioni riguardo a questo CMS, e m'è sembrata un'ottima idea
Pluralitas non est ponenda sine necessitate.
24/03/2011 18:01
Avatar
Abisem
Post: 211
Sto incontrando un altro problema: creo un nuovo tema, vado a creare il CSS relativo, ma al momento di salvare mi risulta nel file di log il seguente errore:

iconCodice:
PHP Fatal error: Uncaught exception 'Exception' with message 'Cannot create file "default.css"' thrown in C:\inetpub\vhosts\origgiweb.it\subdomains\missregina\httpdocs\system\libraries\File.php on line 109


Presumendo si trattasse (nuovamente) di un problema di permessi ho fatto un po' di verifiche: i permessi al file localconfig.php e alle cartelle indicate da PaoloB sono settati correttamente. Per scrupolo ho provato a settare i permessi di scrittura a tutte le cartelle di Contao, ma l'errore è il medesimo.

Ho tentato con il "safe mode hack", impostato tutti i parametri corretti (non sono riuscito a trovare dove si testano nell'admin), ma l'unica cosa che cambia è che ora l'errore anziché scriverlo nel file di log me lo riporta a video.

Ho fatto una verifica con il contao-check.php e il risultato è il seguente:
http://img98.imageshack.us/f/contaocheck.jpg/

Nel forum ho visto che l'ultimo warning riguarda la localizzazione in italiano, e infatti è l'unica cosa che non vada nel file. Quello che non capisco sono i primi due controlli, perché, escluso le SOAP che devo verificare, nel php.ini ho portato l'upload a 8M, mentre nel secondo gli errori sembrano dati da permessi di scrittura, ma io li ho assegnati a tutte le cartelle...

Qualche suggerimento?
Pluralitas non est ponenda sine necessitate.
28/03/2011 23:51
Avatar
PaoloB
Moderatore
Post: 1550
iconAbisem:
Qualche suggerimento?


si, scusami...
il check è chiaro ed io non ero stato esplicito.

I permessi in scrittura devi averli anche sulla root del sito. Sulla root Contao si va a creare i file .css
Paolo B.
paolob@contaocms.it
29/03/2011 00:01
Avatar
Abisem
Post: 211
iconPaoloB:

si, scusami...
il check è chiaro ed io non ero stato esplicito.


Figurati, sei fin troppo disponibile.

iconPaoloB:

I permessi in scrittura devi averli anche sulla root del sito. Sulla root Contao si va a creare i file .css


Ah ecco, non immaginavo che scrivesse i file direttamente sulla root, è una cosa un po' curiosa per un CMS così ordinato, no?

Cmq dando il permesso da Plesk non funzionava lo stesso, ho dovuto abilitare i permessi di scrittura direttamente all'utente IUSR e adesso non ho più bisogno del safe hack mode, che comunque non funzionava.

Per il discorso delle SOAP dici che può crearmi qualche problema o posso ignorarlo?
Pluralitas non est ponenda sine necessitate.
29/03/2011 00:17
Avatar
PaoloB
Moderatore
Post: 1550
iconAbisem:
Per il discorso delle SOAP dici che può crearmi qualche problema o posso ignorarlo?


No, non ti crea alcun problema.

Come detto in un recente post, esiste un'estensione che si chiama NuSoap che ti fa gestire il repository delle estensioni anche senza Soap.
L'unica cosa è che devi installare questa estensione a mano, copiando i file nella system/modules
Paolo B.
paolob@contaocms.it
29/03/2011 00:24
icon