Requisiti di sistema

Si suggerisce di leggere attentamente la lista dei requisiti di sistema qui di seguito per assicurarsi di disporre di tutte le caratteristiche per utilizzare al meglio Contao.
Si ricorda che Contao non funziona con PHP4


Contao richiede un web server come Apache o IIS con supporto PHP e MySQL. La versione minima di PHP è 5.2 e la versione minima di MySQL è 4.1, tuttavia si consiglia di utilizzare MySQL 5 per avere prestazione migliori. È inoltre necessario anche la presenza delle estensioni PHP GDlib (il ridimensionamento delle immagini) e SOAP (Extension Repository) e, facoltativamente, mbstring (manipolazione di caratteri multi-byte) e mcrypt (crittografia dei dati). Contao è stato testato con successo con tutti i maggiori browser come Firefox (dalla versione 2) o Internet Explorer (dalla versione 7).
Sistema Operativo UNIX, Linux, Windows oppure MAC
Web Server Apache (raccomandato) oppure IIS
Linguaggio di scripting PHP dalla versione 5.1.0
Databases supportati MySQL dalla versione 4.1, MySQLi dalla versione 4.1
Estensioni PHP richieste GDLib (immagini e grafica)
Estensioni PHP opzionali mbstring , mcrypt
Compatibilità Web Browser Firefox dalla versione 1.0, Mozilla dalla versione 1.7, Netscape dalla versione 7, Internet Explorer dalla version3 5.5, Opera dalla versione 7